Who are you guys?

V reg ford fiesta 1.25 zetec



An air-lock in the cooling system may cause the symptoms you've described.
Have you recently drained/refilled your coolant. Or had to top up the header tank because the level had dropped out of sight. If so you may have caused an air-lock in the cooling system. With the engine cold; take off the header tank cap and fill the coolant to the 'max' level, cover the header tank with towelling, start the engine and let it run 'til the fan cuts in (all the while watching the level and topping up as necessary + a good squeeze of the hoses during this process is useful to dislodge bubbles). Once the fan has cut in, stop the motor and leave it to cool down - ideally overnight - once cool, top up as needed and then replace the cap. This should remove air pockets from the system.

I have solved the problem by changing the heater valve it only took 20 min's at the most and cost £16 from Ebay, anyone who has this problem have a go it.s so easy and saves you a packet. I would still like to know the location of the thermostat please as i have not yet got a manual for the car which is a 1.25 Zetec v reg 2000

I have solved the problem by changing the heater valve it only took 20 min's at the most and cost £16 from Ebay, anyone who has this problem have a go it's so easy and saves you a packet. I would still like to know the location of the thermostat please as i have not yet got a manual for the car which is a 1.25 Zetec v reg 2000 Thanks Grahame.

fiesta 2001 heater was blowing cold have now replaced valve with second hand one, i can now get hot and cold blow but running temp now rockets into red on dial. Have just finished airlock routine as you suggested if still a problem tomorrow am
What else can i try.
running temp has never shown more than midway on dial in the 5 years i have owned the car.

Thursday, 26 October 2006
Edited Thursday, 26 October 2006

Just had a thought. does anybody think that a total drain down and refill will help if prob still persists